Vi opdaterer PHP til version 7.2

“Den 3. december 2018 fjerner vi PHP version 5.6 og 7.0 fra vores servere. Alle webhoteller, der bruger disse versioner på det pågældende tidspunkt, opdateres til PHP 7.2.”


Den 3. december 2018 fjerner vi PHP version 5.6 og 7.0 fra vores servere. Alle de webhoteller, der bruger disse versioner på det pågældende tidspunkt, opdateres til PHP 7.2. Årsagen til disse opdateringer er, at PHP 5.6 og 7.0 har nået slutningen af deres levetid.

I første halvdel af november opdaterer vi alle de webhoteller, der bruger PHP 5.6 eller 7.0, til version 7.2. På dette tidspunkt kan du stadigvæk gå tilbage til den tidligere PHP-version. Hvis dit websted ikke fungerer som forventet efter opdateringen, har du stadigvæk et par uger til at foretage rettelser.

Hvad betyder det, når en PHP-version når til slutningen af dens levetid?

Alle PHP-versioner har en livscyklus på omkring tre år. Efter den indledende udgivelse, ydes der aktivt support til en PHP-version i to år. I denne periode udgives der regelmæssigt versioner, der retter fejl og sikkerhedsproblemer.

Efter disse to år ydes der support til PHP-versionen i endnu et år, men kun i forbindelse med kritiske sikkerhedsopdateringer. Et år senere når PHP-versionen til slutningen af dens levetid, og der ydes ikke længere support af PHP.net. Det betyder, at selv kritiske sikkerhedsfejl ikke længere rettes, hvilket gør PHP langt mere udsat for risici.
Læs vores vejledning for at få mere at vide om årsagerne til opdatering af PHP: Hvorfor bør jeg opdatere PHP?

Påvirkes dit websted?

Det kommer an på flere ting. Hvis dit websted er oprettet med HTML, f.eks. Website Builder, påvirkes det ikke. Hvis dit websted bruger PHP, f.eks. WordPress, påvirkes det muligvis.

Om dit websted påvirkes eller ej afhænger i høj grad af, om du har opdateret dit CMS og dine plugins til den nyeste version for nylig. Hvis du jævnligt opdaterer dit websted, bør PHP-opdateringen ikke være noget problem, tværtimod. Opdateringen kan forbedre ydeevnen for dit websted, især hvis det kører på WordPress.

Hvordan ved du, hvilken version af PHP du bruger i øjeblikket?

Det kan du se i kontrolpanelet på One.com under PHP & Database – Maria DB. Her kan du se den version, du bruger i øjeblikket og skifte til en anden version. Husk, at det kun tager 20 minutter, før ændringen træder i kraft.

Hvis dit websted bruger PHP 5.6 eller PHP 7.0, får du også en mail fra os, hvor vi informerer dig om den kommende opdatering.

Hvad skal jeg foretage mig, hvis min nuværende PHP-version er 5.6 eller 7.0?

Hvis det er tilfældet, skal du helst opdatere til PHP 7.2, fordi det er den nyeste version, hvor der er længst supporttid tilbage, nemlig til november 2020.

Vi anbefaler, at du gør det hurtigst muligt, før supporten til PHP 5.6 og 7.0 stopper den 3. december. På den måde kan du stadigvæk gå tilbage til den forrige version, hvis det viser sig, at dit websted ikke fungerer som forventet. Hvis du gendanner til den forrige version af PHP, fungerer dit websted igen, og du får tid til at foretage rettelser.

Hvordan kan jeg gøre mit websted kompatibelt med PHP 7.2?

Hvis du bruger et CMS, f.eks. WordPress, er det ligetil: Opdater alt til den nyeste version, inklusive dine plugins og temaer.

Bruger du den nyeste version af dit CMS og har alligevel problemer? Så skyldes det højst sandsynligt et plugin eller et tema. Du kan finde ud af, hvad der er årsag til problemerne ved at deaktivere alle plugins og temaer, der ikke er installeret som standard. Herefter skal du opdatere PHP til 7.2 og derefter genaktivere alle plugins og temaer igen.

Tjek vores trinvise vejledning i, hvordan du opdaterer PHP til WordPress på sikker vis: Hvordan opdaterer jeg PHP til mit WordPress-websted?

Hvis du bruger PHP-kode på dit websted, der er skræddersyet til dit websted, er opdateringen lidt mere vanskelig. Koden skal med stor sandsynlighed skrives på ny af en udvikler for at gøre den kompatibel. Du kan få flere oplysninger ved at tjekke vores vejledning med tips til, hvordan du griber det an.

Er der fordele ved at opdatere PHP?

Ja, det er der! Som med alt andet på internettet udvikles og forbedres PHP løbende. Hver version er en lille smule bedre end den forrige. Sammenlignet med PHP 5.6 gør PHP 7.2 f.eks. WordPress-websteder to gange mere responsive i gennemsnit.

Der er også det sikkerhedsmæssige aspekt. En stor del af den forældede kode er blevet fjernet i PHP 7.2, hvilket giver hackere færre muligheder for at udnytte koden og gør koden mere robust.

Comments